re = /R?[CD]\d+(?:[,.]\d+)?/m
str = '8372C8932,25adfadf
82912RC839,00klsd
87D74,23lsdf
97571RD876,55adsf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end