$re = '/R?[CD]\d+(?:[,.]\d+)?/m';
$str = '8372C8932,25adfadf
82912RC839,00klsd
87D74,23lsdf
97571RD876,55adsf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);