package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)R?[CD]\d+(?:[,.]\d+)?`)
var str = `8372C8932,25adfadf
82912RC839,00klsd
87D74,23lsdf
97571RD876,55adsf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}