// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)R?[CD]\d+(?:[,.]\d+)?").unwrap();
let string = "8372C8932,25adfadf
82912RC839,00klsd
87D74,23lsdf
97571RD876,55adsf";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}