using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:<[^\/]*?.*?<\/.*?>)|(:\/)";
string substitution = @"xxxxxxxxx";
string input = @"not feeling well today :/ check out this link <a href=""http://example.com"">http://example.com</a>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}