use strict;
my $str = 'not feeling well today :/ check out this link <a href="http://example.com">http://example.com</a>';
my $regex = qr/(?:<[^\/]*?.*?<\/.*?>)|(:\/)/p;
my $subst = 'xxxxxxxxx';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";