$re = '/(?:<[^\/]*?.*?<\/.*?>)|(:\/)/';
$str = 'not feeling well today :/ check out this link <a href="http://example.com">http://example.com</a>';
$subst = "xxxxxxxxx";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;