// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:<[^\/]*?.*?<\/.*?>)|(:\/)").unwrap();
let string = "not feeling well today :/ check out this link <a href=\"http://example.com\">http://example.com</a>";
let substitution = "xxxxxxxxx";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}