import Foundation
let pattern = #"(?:<[^\/]*?.*?<\/.*?>)|(:\/)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"not feeling well today :/ check out this link <a href="http://example.com">http://example.com</a>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"xxxxxxxxx"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)