import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:<[^\\/]*?.*?<\\/.*?>)|(:\\/)";
final String string = "not feeling well today :/ check out this link <a href=\"http://example.com\">http://example.com</a>";
final String subst = "xxxxxxxxx";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}