use strict;
my $str = '<option value="91">Afghanistan</option>';
my $regex = qr/"([^"]*)">([^]]*)</p;
my $subst = '"\\2">\\1<';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";