#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)^(?:20(?:1[4-9]|[2-9][0-9])|2[1-9][0-9][0-9]|[3-9][0-9][0-9][0-9])$"
Local $sString = "2014" & @CRLF & _
"9999" & @CRLF & _
"2010" & @CRLF & _
"2015" & @CRLF & _
"9999" & @CRLF & _
"8888" & @CRLF & _
"3400" & @CRLF & _
"0000" & @CRLF & _
"2013" & @CRLF & _
"8987" & @CRLF & _
"635737838" & @CRLF & _
"7864" & @CRLF & _
"4567" & @CRLF & _
""
Local $sSubst = "\1{0},0"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)