import re
regex = re.compile(r"^(?:20(?:1[4-9]|[2-9][0-9])|2[1-9][0-9][0-9]|[3-9][0-9][0-9][0-9])$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("2014\n"
"9999\n"
"2010\n"
"2015\n"
"9999\n"
"8888\n"
"3400\n"
"0000\n"
"2013\n"
"8987\n"
"635737838\n"
"7864\n"
"4567\n")
subst = "\\1{0},0"
result = regex.sub(subst, test_str)
if result:
print(result)