import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:20(?:1[4-9]|[2-9][0-9])|2[1-9][0-9][0-9]|[3-9][0-9][0-9][0-9])$";
final String string = "2014\n"
+ "9999\n"
+ "2010\n"
+ "2015\n"
+ "9999\n"
+ "8888\n"
+ "3400\n"
+ "0000\n"
+ "2013\n"
+ "8987\n"
+ "635737838\n"
+ "7864\n"
+ "4567\n";
final String subst = "\\1{0},0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}