// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(?:20(?:1[4-9]|[2-9][0-9])|2[1-9][0-9][0-9]|[3-9][0-9][0-9][0-9])$").unwrap();
let string = "2014
9999
2010
2015
9999
8888
3400
0000
2013
8987
635737838
7864
4567
";
let substitution = "\\1{0},0";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}