$re = '/^(?:20(?:1[4-9]|[2-9][0-9])|2[1-9][0-9][0-9]|[3-9][0-9][0-9][0-9])$/mi';
$str = '2014
9999
2010
2015
9999
8888
3400
0000
2013
8987
635737838
7864
4567
';
$subst = "\1{0},0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;