const regex = /^(?:20(?:1[4-9]|[2-9][0-9])|2[1-9][0-9][0-9]|[3-9][0-9][0-9][0-9])$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:20(?:1[4-9]|[2-9][0-9])|2[1-9][0-9][0-9]|[3-9][0-9][0-9][0-9])$', 'gmi')
const str = `2014
9999
2010
2015
9999
8888
3400
0000
2013
8987
635737838
7864
4567
`;
const subst = `\1{0},0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);