import Foundation
let pattern = #"^(?:20(?:1[4-9]|[2-9][0-9])|2[1-9][0-9][0-9]|[3-9][0-9][0-9][0-9])$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
2014
9999
2010
2015
9999
8888
3400
0000
2013
8987
635737838
7864
4567
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1{0},0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)