# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((\d{4})-(\d{2})-(\d{2})) ((\d{2}):(\d{2}):(\d{2}))/日期\1 时间\5 \2年\3月\4日 \6时\7分\8秒/g;t' <<< "2020-05-10 20:23:05"