import re
regex = re.compile(r"((\d{4})-(\d{2})-(\d{2})) ((\d{2}):(\d{2}):(\d{2}))")
test_str = "2020-05-10 20:23:05"
subst = "日期\\1 时间\\5 \\2年\\3月\\4日 \\6时\\7分\\8秒"
result = regex.sub(subst, test_str)
if result:
print(result)