import Foundation
let pattern = #"((\d{4})-(\d{2})-(\d{2})) ((\d{2}):(\d{2}):(\d{2}))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"2020-05-10 20:23:05"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"日期\1 时间\5 \2年\3月\4日 \6时\7分\8秒"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)