re = /((\d{4})-(\d{2})-(\d{2})) ((\d{2}):(\d{2}):(\d{2}))/
str = '2020-05-10 20:23:05'
subst = '日期\\1 时间\\5 \\2年\\3月\\4日 \\6时\\7分\\8秒'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result