const regex = /((\d{4})-(\d{2})-(\d{2})) ((\d{2}):(\d{2}):(\d{2}))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((\\d{4})-(\\d{2})-(\\d{2})) ((\\d{2}):(\\d{2}):(\\d{2}))', 'g')
const str = `2020-05-10 20:23:05`;
const subst = `日期\1 时间\5 \2年\3月\4日 \6时\7分\8秒`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);