using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((\d{4})-(\d{2})-(\d{2})) ((\d{2}):(\d{2}):(\d{2}))";
string substitution = @"日期\1 时间\5 \2年\3月\4日 \6时\7分\8秒";
string input = @"2020-05-10 20:23:05";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}