#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\|links *= *(\s*?.*?)*?^"
Local $sString = "{{Song box 2" & @CRLF & _
" |color = black; color:#D7DA5F" & @CRLF & _
" |image = Kokoropv.jpg" & @CRLF & _
" |title = "'''ココロ'''"" & @CRLF & _
"* Romaji: Kokoro" & @CRLF & _
"* Official English: Heart" & @CRLF & _
" |date = March 2, 2008" & @CRLF & _
" |views = {{v|nn|2,738,496}}" & @CRLF & _
" |singers = [[Kagamine Rin]] act1" & @CRLF & _
" |producers = [[Toraboruta-P]] (music, lyrics, illustration)" & @CRLF & _
" |links = {{l|nn|sm2500648}} {{l|mz|266689|defunct}}" & @CRLF & _
" |links = {{l|nn|sm2500648}} {{l|mz|266689|defunct}}" & @CRLF & _
"}}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")