# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\|links *= *(\s*?.*?)*?^"
test_str = ("{{Song box 2\n"
" |color = black; color:#D7DA5F\n"
" |image = Kokoropv.jpg\n"
" |title = "'''ココロ'''"\n"
"* Romaji: Kokoro\n"
"* Official English: Heart\n"
" |date = March 2, 2008\n"
" |views = {{v|nn|2,738,496}}\n"
" |singers = [[Kagamine Rin]] act1\n"
" |producers = [[Toraboruta-P]] (music, lyrics, illustration)\n"
" |links = {{l|nn|sm2500648}} {{l|mz|266689|defunct}}\n"
" |links = {{l|nn|sm2500648}} {{l|mz|266689|defunct}}\n"
"}}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.