using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\|links *= *(\s*?.*?)*?^";
string input = @"{{Song box 2
|color = black; color:#D7DA5F
|image = Kokoropv.jpg
|title = "'''ココロ'''"
* Romaji: Kokoro
* Official English: Heart
|date = March 2, 2008
|views = {{v|nn|2,738,496}}
|singers = [[Kagamine Rin]] act1
|producers = [[Toraboruta-P]] (music, lyrics, illustration)
|links = {{l|nn|sm2500648}} {{l|mz|266689|defunct}}
|links = {{l|nn|sm2500648}} {{l|mz|266689|defunct}}
}}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}