re = /\|links *= *(\s*?.*?)*?^/m
str = '{{Song box 2
|color = black; color:#D7DA5F
|image = Kokoropv.jpg
|title = "\'\'\'ココロ\'\'\'"
* Romaji: Kokoro
* Official English: Heart
|date = March 2, 2008
|views = {{v|nn|2,738,496}}
|singers = [[Kagamine Rin]] act1
|producers = [[Toraboruta-P]] (music, lyrics, illustration)
|links = {{l|nn|sm2500648}} {{l|mz|266689|defunct}}
|links = {{l|nn|sm2500648}} {{l|mz|266689|defunct}}
}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end