// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\|links *= *(\s*?.*?)*?^").unwrap();
let string = "{{Song box 2
|color = black; color:#D7DA5F
|image = Kokoropv.jpg
|title = "'''ココロ'''"
* Romaji: Kokoro
* Official English: Heart
|date = March 2, 2008
|views = {{v|nn|2,738,496}}
|singers = [[Kagamine Rin]] act1
|producers = [[Toraboruta-P]] (music, lyrics, illustration)
|links = {{l|nn|sm2500648}} {{l|mz|266689|defunct}}
|links = {{l|nn|sm2500648}} {{l|mz|266689|defunct}}
}}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}