import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\|links *= *(\\s*?.*?)*?^";
final String string = "{{Song box 2\n"
+ " |color = black; color:#D7DA5F\n"
+ " |image = Kokoropv.jpg\n"
+ " |title = "'''ココロ'''"\n"
+ "* Romaji: Kokoro\n"
+ "* Official English: Heart\n"
+ " |date = March 2, 2008\n"
+ " |views = {{v|nn|2,738,496}}\n"
+ " |singers = [[Kagamine Rin]] act1\n"
+ " |producers = [[Toraboruta-P]] (music, lyrics, illustration)\n"
+ " |links = {{l|nn|sm2500648}} {{l|mz|266689|defunct}}\n"
+ " |links = {{l|nn|sm2500648}} {{l|mz|266689|defunct}}\n"
+ "}}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}