import Foundation
let pattern = #"\|links *= *(\s*?.*?)*?^"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
{{Song box 2
  |color     = black; color:#D7DA5F
  |image     = Kokoropv.jpg
  |title     = "'''ココロ'''"
* Romaji: Kokoro
* Official English: Heart
  |date      = March 2, 2008
  |views     = {{v|nn|2,738,496}}
  |singers   = [[Kagamine Rin]] act1
  |producers = [[Toraboruta-P]] (music, lyrics, illustration)
  |links     = {{l|nn|sm2500648}} {{l|mz|266689|defunct}}
  |links = {{l|nn|sm2500648}} {{l|mz|266689|defunct}}
}}
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
    var groups: [String] = []
    for rangeIndex in 1 ..< match.numberOfRanges {
        let nsRange = match.range(at: rangeIndex)
        guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
        let string = (testString as NSString).substring(with: nsRange)
        groups.append(string)
    }
    if !groups.isEmpty {
        result.append(groups)
    }
}
print(result)