#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^(?:\d)\.\d*)|(10\.?0*$)"
Local $sString = "" & @CRLF & _
"Valid numbers" & @CRLF & _
"0.23" & @CRLF & _
"1.02" & @CRLF & _
"6.2" & @CRLF & _
"7.20" & @CRLF & _
"10.00" & @CRLF & _
"10" & @CRLF & _
"5.656563211235435454643234656563211235435454643234656563211235435454643234656563211235435454643234" & @CRLF & _
"" & @CRLF & _
"Invalid numbers:" & @CRLF & _
"10.01" & @CRLF & _
"12.333" & @CRLF & _
" 5.656563211235435454643234656563211235435454643234656563211235435454643234656563211235435454643234" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")