using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^(?:\d)\.\d*)|(10\.?0*$)";
string input = @"
Valid numbers
0.23
1.02
6.2
7.20
10.00
10
5.656563211235435454643234656563211235435454643234656563211235435454643234656563211235435454643234
Invalid numbers:
10.01
12.333
5.656563211235435454643234656563211235435454643234656563211235435454643234656563211235435454643234
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}