re = /(^(?:\d)\.\d*)|(10\.?0*$)/m
str = '
Valid numbers
0.23
1.02
6.2
7.20
10.00
10
5.656563211235435454643234656563211235435454643234656563211235435454643234656563211235435454643234
Invalid numbers:
10.01
12.333
5.656563211235435454643234656563211235435454643234656563211235435454643234656563211235435454643234
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end