package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^(?:\d)\.\d*)|(10\.?0*$)`)
var str = `
Valid numbers
0.23
1.02
6.2
7.20
10.00
10
5.656563211235435454643234656563211235435454643234656563211235435454643234656563211235435454643234
Invalid numbers:
10.01
12.333
5.656563211235435454643234656563211235435454643234656563211235435454643234656563211235435454643234
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}