use strict;
my $str = '
Valid numbers
0.23
1.02
6.2
7.20
10.00
10
5.656563211235435454643234656563211235435454643234656563211235435454643234656563211235435454643234
Invalid numbers:
10.01
12.333
5.656563211235435454643234656563211235435454643234656563211235435454643234656563211235435454643234
';
my $regex = qr/(^(?:\d)\.\d*)|(10\.?0*$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}