import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^(?:\\d)\\.\\d*)|(10\\.?0*$)";
final String string = "\n"
+ "Valid numbers\n"
+ "0.23\n"
+ "1.02\n"
+ "6.2\n"
+ "7.20\n"
+ "10.00\n"
+ "10\n"
+ "5.656563211235435454643234656563211235435454643234656563211235435454643234656563211235435454643234\n\n"
+ "Invalid numbers:\n"
+ "10.01\n"
+ "12.333\n"
+ " 5.656563211235435454643234656563211235435454643234656563211235435454643234656563211235435454643234\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}