// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^(?:\d)\.\d*)|(10\.?0*$)").unwrap();
let string = "
Valid numbers
0.23
1.02
6.2
7.20
10.00
10
5.656563211235435454643234656563211235435454643234656563211235435454643234656563211235435454643234
Invalid numbers:
10.01
12.333
5.656563211235435454643234656563211235435454643234656563211235435454643234656563211235435454643234
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}