#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\$\d+(,\d{3})*( *, *\$\d+(,\d{3})*){4}$"
Local $sString = "$200,000,$525,$60000,$120,000,$65,456" & @CRLF & _
"$200,000, $525, $60000,$120,000, $65,456" & @CRLF & _
"$200,000,$525,$60000,$120,000,$65,456, " & @CRLF & _
"$200,000,,$525,$60000.$120,000,$65,456,,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")