// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\$\d+(,\d{3})*( *, *\$\d+(,\d{3})*){4}$").unwrap();
let string = "$200,000,$525,$60000,$120,000,$65,456
$200,000, $525, $60000,$120,000, $65,456
$200,000,$525,$60000,$120,000,$65,456,
$200,000,,$525,$60000.$120,000,$65,456,,";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}