import re
regex = re.compile(r"^\$\d+(,\d{3})*( *, *\$\d+(,\d{3})*){4}$", flags=re.MULTILINE)
test_str = ("$200,000,$525,$60000,$120,000,$65,456\n"
"$200,000, $525, $60000,$120,000, $65,456\n"
"$200,000,$525,$60000,$120,000,$65,456, \n"
"$200,000,,$525,$60000.$120,000,$65,456,,")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")