import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\$\\d+(,\\d{3})*( *, *\\$\\d+(,\\d{3})*){4}$";
final String string = "$200,000,$525,$60000,$120,000,$65,456\n"
+ "$200,000, $525, $60000,$120,000, $65,456\n"
+ "$200,000,$525,$60000,$120,000,$65,456, \n"
+ "$200,000,,$525,$60000.$120,000,$65,456,,";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}