$re = '/^\$\d+(,\d{3})*( *, *\$\d+(,\d{3})*){4}$/m';
$str = '$200,000,$525,$60000,$120,000,$65,456
$200,000, $525, $60000,$120,000, $65,456
$200,000,$525,$60000,$120,000,$65,456,
$200,000,,$525,$60000.$120,000,$65,456,,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);