const regex = /^\$\d+(,\d{3})*( *, *\$\d+(,\d{3})*){4}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\$\\d+(,\\d{3})*( *, *\\$\\d+(,\\d{3})*){4}$', 'gm')
const str = `\$200,000,\$525,\$60000,\$120,000,\$65,456
\$200,000, \$525, \$60000,\$120,000, \$65,456
\$200,000,\$525,\$60000,\$120,000,\$65,456,
\$200,000,,\$525,\$60000.\$120,000,\$65,456,,`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}