re = /^\$\d+(,\d{3})*( *, *\$\d+(,\d{3})*){4}$/m
str = '$200,000,$525,$60000,$120,000,$65,456
$200,000, $525, $60000,$120,000, $65,456
$200,000,$525,$60000,$120,000,$65,456,
$200,000,,$525,$60000.$120,000,$65,456,,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end