# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?<!\\)(?:\\{2})*)["']/$1/gm;t' <<< "\"value\" -> value
'value' -> value
\"\\"value\\"\" -> \\"value\\" <-- contains escaped quotes
\"value\\" -> value\\"
\"value\\\" -> value\\ <-- contains escaped backslash before non-escaped quote
\"\"\"val\"ue\\\\"\"\" -> value\\\\""