using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?<!\\)(?:\\{2})*)[""']";
string substitution = @"$1";
string input = @"""value"" -> value
'value' -> value
""\""value\"" -> \""value\"" <-- contains escaped quotes
""value\"" -> value\""
""value\\"" -> value\\ <-- contains escaped backslash before non-escaped quote
""""val""ue\\\"""" -> value\\\""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}