import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?<!\\\\)(?:\\\\{2})*)[\"']";
final String string = "\"value\" -> value\n"
+ "'value' -> value\n"
+ "\"\\\"value\\\"\" -> \\\"value\\\" <-- contains escaped quotes\n"
+ "\"value\\\" -> value\\\"\n"
+ "\"value\\\\\" -> value\\\\ <-- contains escaped backslash before non-escaped quote\n"
+ "\"\"\"val\"ue\\\\\\\"\"\" -> value\\\\\\\"";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}