#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((?<!\\)(?:\\{2})*)["']"
Local $sString = ""value" -> value" & @CRLF & _
"'value' -> value" & @CRLF & _
""\"value\"" -> \"value\" <-- contains escaped quotes" & @CRLF & _
""value\" -> value\"" & @CRLF & _
""value\\" -> value\\ <-- contains escaped backslash before non-escaped quote" & @CRLF & _
""""val"ue\\\""" -> value\\\""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)