re = /((?<!\\)(?:\\{2})*)["']/m
str = '"value" -> value
\'value\' -> value
"\\"value\\"" -> \\"value\\" <-- contains escaped quotes
"value\\" -> value\\"
"value\\\\" -> value\\\\ <-- contains escaped backslash before non-escaped quote
"""val"ue\\\\\\""" -> value\\\\\\"'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result